2014-07-10

CentOS-7: Full install

So CentOS-7 was released last week, and I finally was able to download it yesterday. One of the reasons for doing so was to have a machine that I could check for conflicts between EL-7 and EPEL. I do this via a very very caveman hack way (warning, there are better ways of doing this.. there must be :)).

So I create a VM and do an everything install of CentOS-7. This usually takes a couple of times as I figure out how much disk space is required. My first attempt I estimated that 24GB would be enough, but turned out I was wrong as various POST and other items would require more space. I ended up making a 32 GB VM and then getting it all to install in steps.

To do the install I mount the CentOS-7-Everything ISO as a cdrom in the VM machine. I then cd in /mnt/Packages and try a


yum localinstall *

This runs for a while and then spits out that there a bunch of conflicts that can't be resolved.

Error: php-mysql conflicts with php-mysqlnd-5.4.16-21.el7.x86_64
Error: libpng12-devel conflicts with 2:libpng-devel-1.5.13-5.el7.i686
Error: libcmpiCppImpl0 conflicts with 2:tog-pegasus-libs-2.12.1-16.el7.i686
Error: libcmpiCppImpl0 conflicts with 2:tog-pegasus-libs-2.12.1-16.el7.x86_64
Error: tog-pegasus-libs conflicts with libcmpiCppImpl0-2.0.3-5.el7.x86_64
Error: tog-pegasus-libs conflicts with libcmpiCppImpl0-2.0.3-5.el7.i686
Error: libpng12-devel conflicts with 2:libpng-devel-1.5.13-5.el7.x86_64


At this point I can do a --skip-broken which leads to the following almost working and then running into some bugs in rpms.

Transaction check error:
  file /usr/include/freeradius/radpaths.h from install of freeradius-devel-3.0.1-6.el7.i686 conflicts with file from package freeradius-devel-3.0.1-6.el7.x86_64
  file /usr/include/bacula/src/host.h from install of bacula-devel-5.2.13-18.el7.i686 conflicts with file from package bacula-devel-5.2.13-18.el7.x86_64
  file /usr/include/ImageMagick/magick/version.h from install of ImageMagick-devel-6.7.8.9-10.el7.i686 conflicts with file from package ImageMagick-devel-6.7.8.9-10.el7.x86_64
  file /usr/include/event2/event-config.h from install of libevent-devel-2.0.21-4.el7.i686 conflicts with file from package libevent-devel-2.0.21-4.el7.x86_64

[root@localhost Packages]# yum -y localinstall *rpm --skip-broken --exclude=freeradius-devel-3.0.1-6.el7.i686 --exclude=bacula-devel-5.2.13-18.el7.i686 --exclude=ImageMagick-devel-6.7.8.9-10.el7.i686 --exclude=libevent-devel-2.0.21-4.el7.i686


Eventually I am able to get everything installed and have

[root@localhost Packages]# rpm -qa | wc -l
8447
[root@localhost Packages]# df
Filesystem              1K-blocks     Used Available Use% Mounted on
/dev/mapper/centos-root  31728500 25849976   5878524  82% /
devtmpfs                  1932608        0   1932608   0% /dev
tmpfs                     1941760        0   1941760   0% /dev/shm
tmpfs                     1941760    16740   1925020   1% /run
tmpfs                     1941760        0   1941760   0% /sys/fs/cgroup
/dev/vda1                 1020588   192696    827892  19% /boot
/dev/sr0                  6896194  6896194         0 100% /mnt


My hat is off to the developers of xz as that is phenomenal compression from a 6+ GB ISO to 25G diskspace. It has been a week since release.. how many updates have been issued so far?

Transaction Summary
=============================================================================================================================
Install    4 Packages
Upgrade  245 Packages

Total size: 659 M
Total download size: 420 M


A short while later we have everything updated and installed and I can see what epel has in it currently:

[root@localhost ~]# wget http://dl.fedoraproject.org/pub/epel/beta/7/x86_64/epel-release-7-0.2.noarch.rpm
[root@localhost ~]# yum -y localinstall epel-release-7-0.2.noarch.rpm
[root@localhost ~]# yum --disablerepo=base --disablerepo=updates --disablerepo=extras install '*' 

...
--> Finished Dependency Resolution
Error: php-pecl-http1 conflicts with php-pecl-http-2.0.6-1.el7.x86_64
Error: Package: gedit-beesu-plugin-0.4-19.el7.x86_64 (epel)
           Requires: python3
Error: php-pecl-http1 conflicts with php-pecl-event-1.10.2-1.el7.x86_64
Error: Package: lyx-2.1.1-1.el7.x86_64 (epel)
           Requires: /usr/bin/chktex
Error: Package: globus-gram-job-manager-pbs-1.6-7.el7.x86_64 (epel)
           Requires: torque-client
Error: php-pecl-http1-devel conflicts with php-pecl-http-devel-2.0.6-1.el7.x86_64
Error: Package: wine-desktop-1.7.21-1.el7.x86_64 (epel)
           Requires: wine-core(x86-32) = 1.7.21-1.el7
Error: Package: tlp-0.5-2.el7.noarch (epel)
           Requires: wireless-tools
Error: Package: lyx-2.1.1-1.el7.x86_64 (epel)
           Requires: tetex-dvipost
Error: compat-qpid-cpp-server-xml conflicts with qpid-cpp-server-xml-0.28-4.el7.x86_64
Error: Package: pyhoca-cli-0.4.0.2-1.el7.noarch (epel)
           Requires: notify-python
Error: Package: rabbitvcs-thunar-0.16-1.el7.x86_64 (epel)
           Requires: thunar
Error: Package: oz-0.12.0-2.el7.noarch (epel)
           Requires: libvirt-daemon-qemu
Error: Package: rubygem-simplecov-0.7.1-8.el7.noarch (epel)
           Requires: rubygem(multi_json) >= 1.0
Error: firebird-classic-common conflicts with firebird-superserver-2.5.2.26539.0-8.el7.x86_64
Error: Package: amavisd-new-2.9.1-1.el7.noarch (epel)
           Requires: cabextract
Error: Package: TurboGears-1.1.3-8.el7.noarch (epel)
           Requires: python-turbokid >= 1.0.5
Error: compat-qpid-cpp-server conflicts with qpid-cpp-server-0.28-4.el7.x86_64
Error: compat-qpid-cpp-client-devel-docs conflicts with qpid-cpp-client-devel-docs-0.28-4.el7.noarch
Error: Package: rubygem-term-ansicolor-1.2.2-3.el7.noarch (epel)
           Requires: rubygem(tins) >= 0.8
Error: Package: TurboGears-1.1.3-8.el7.noarch (epel)
           Requires: python-turbojson >= 1.3
Error: Package: lyx-2.1.1-1.el7.x86_64 (epel)
           Requires: /usr/bin/dv2dt
Error: Package: 1:python-flask-0.10.1-3.el7.noarch (epel)
           Requires: python-itsdangerous
Error: Package: inxi-2.1.28-1.el7.noarch (epel)
           Requires: hddtemp
Error: tomcatjss conflicts with tomcat-native-1.1.30-1.el7.x86_64
Error: Package: TurboGears-1.1.3-8.el7.noarch (epel)
           Requires: python-turbocheetah >= 1.0
Error: Package: wine-1.7.21-1.el7.x86_64 (epel)
           Requires: wine-cms(x86-32) = 1.7.21-1.el7
Error: Package: lxc-templates-0.9.0-3.el7.x86_64 (epel)
           Requires: dpkg
Error: compat-qpid-cpp-client-devel conflicts with qpid-cpp-client-devel-0.28-4.el7.x86_64
Error: Package: amavisd-new-2.9.1-1.el7.noarch (epel)
           Requires: altermime
Error: Package: datagrepper-0.4.1-3.el7.noarch (epel)
           Requires: python-backports-lzma
Error: Package: wine-1.7.21-1.el7.x86_64 (epel)
           Requires: wine-openal(x86-32) = 1.7.21-1.el7
Error: Package: amavisd-new-2.9.1-1.el7.noarch (epel)
           Requires: perl(Convert::TNEF)
Error: Package: rubygem-rspec-expectations-2.14.5-2.el7.1.noarch (epel)
           Requires: rubygem(diff-lcs)
Error: libev-libevent-devel conflicts with libevent-devel-2.0.21-4.el7.x86_64
Error: Package: perl-Protocol-WebSocket-0.17-1.el7.noarch (epel)
           Requires: perl(AnyEvent::Handle)
Error: Package: fldigi-3.21.83-1.el7.x86_64 (epel)
           Requires: perl(RPC::XML::Client)
Error: Package: 2ping-2.0-2.el7.noarch (epel)
           Requires: perl(Digest::CRC)
Error: Package: openpgpkey-milter-0.3-1.el7.noarch (epel)
           Requires: python-pymilter
Error: Package: amavisd-new-2.9.1-1.el7.noarch (epel)
           Requires: perl(Unix::Syslog)
Error: Package: rubygem-rspec-2.14.1-1.el7.noarch (epel)
           Requires: rubygem(rspec-core) >= 2.14.1
Error: compat-qpid-cpp-server-ha conflicts with qpid-cpp-server-ha-0.28-4.el7.x86_64
Error: Package: nagios-plugins-openmanage-3.7.11-1.el7.x86_64 (epel)
           Requires: perl(Crypt::Rijndael)
Error: compat-qpid-cpp-client-rdma conflicts with qpid-cpp-client-rdma-0.28-4.el7.x86_64
Error: Package: caja-beesu-manager-1.8-19.el7.noarch (epel)
           Requires: /usr/bin/pluma
Error: Package: rubygem-mizuho-0.9.20-2.el7.noarch (epel)
           Requires: rubygem(sqlite3)
Error: compat-qpid-cpp-server-store conflicts with qpid-cpp-server-store-0.28-4.el7.x86_64
Error: compat-qpid-cpp-client conflicts with qpid-cpp-client-0.28-4.el7.x86_64
Error: Package: wine-1.7.21-1.el7.x86_64 (epel)
           Requires: wine-core(x86-32) = 1.7.21-1.el7
Error: Package: globus-gram-job-manager-sge-1.7-2.el7.x86_64 (epel)
           Requires: gridengine
Error: Package: openpgpkey-milter-0.3-1.el7.noarch (epel)
           Requires: python-gnupg
Error: Package: dislocker-0.3.1-2.20140423git.el7.x86_64 (epel)
           Requires: libpolarssl.so.5()(64bit)
Error: Package: lyx-2.1.1-1.el7.x86_64 (epel)
           Requires: tex-simplecv
Error: GtkAda3-devel conflicts with GtkAda-devel-2.24.2-8.el7.x86_64
Error: Package: TurboGears-1.1.3-8.el7.noarch (epel)
           Requires: python-cherrypy2
Error: Package: TurboGears-1.1.3-8.el7.noarch (epel)
           Requires: python-peak-rules
Error: firebird-superclassic conflicts with firebird-classic-2.5.2.26539.0-8.el7.x86_64
Error: Package: wine-1.7.21-1.el7.x86_64 (epel)
           Requires: wine-ldap(x86-32) = 1.7.21-1.el7
Error: Package: fuse-dislocker-0.3.1-2.20140423git.el7.x86_64 (epel)
           Requires: libpolarssl.so.5()(64bit)
Error: Package: perl-Protocol-WebSocket-0.17-1.el7.noarch (epel)
           Requires: perl(AnyEvent::Socket)
Error: Package: rabbitvcs-core-0.16-1.el7.noarch (epel)
           Requires: pysvn
Error: Package: lyx-2.1.1-1.el7.x86_64 (epel)
           Requires: wv
Error: Package: zarafa-search-7.1.10-1.el7.x86_64 (epel)
           Requires: catdoc
Error: Package: amavisd-new-2.9.1-1.el7.noarch (epel)
           Requires: unzoo
Error: Package: tor-0.2.4.22-2.el7.x86_64 (epel)
           Requires: torsocks
Error: Package: yumex-3.0.15-1.el7.noarch (epel)
           Requires: udisks
Error: Package: wine-1.7.21-1.el7.x86_64 (epel)
           Requires: wine-twain(x86-32) = 1.7.21-1.el7
Error: Package: perl-Protocol-WebSocket-0.17-1.el7.noarch (epel)
           Requires: perl(AnyEvent)
Error: Package: zarafa-search-7.1.10-1.el7.x86_64 (epel)
           Requires: w3m
Error: Package: RemoteBox-1.8.1-1.el7.noarch (epel)
           Requires: rdesktop
Error: Package: rubygem-gssapi-1.1.2-3.el7.noarch (epel)
           Requires: rubygem(ffi) >= 1.0.1
Error: Package: pyhoca-gui-0.4.0.9-2.el7.noarch (epel)
           Requires: notify-python
Error: libev-libevent-devel conflicts with libevent-devel-2.0.21-4.el7.i686
Error: php-pecl-uuid conflicts with uuid-php-1.6.2-26.el7.x86_64
Error: Package: amavisd-new-snmp-2.9.1-1.el7.noarch (epel)
           Requires: perl(Unix::Syslog)
Error: Package: amavisd-new-2.9.1-1.el7.noarch (epel)
           Requires: clamav-server-systemd
Error: Package: qt4pas-2.5-3.el7.x86_64 (epel)
           Requires: fpc-src
Error: Package: freight-0.3.5-4.el7.noarch (epel)
           Requires: dpkg
Error: Package: lxc-templates-0.9.0-3.el7.x86_64 (epel)
           Requires: busybox
Error: Package: dpm-xrootd-3.3.4-1.el7.x86_64 (epel)
           Requires: libXrdUtils.so.1()(64bit)
Error: Package: ewftools-20130416-1.el7.x86_64 (epel)
           Requires: fuse-python >= 0.2
Error: mariadb-galera-server conflicts with 1:mariadb-server-5.5.37-1.el7_0.x86_64
Error: Package: nf3d-0.8-2.el7.noarch (epel)
           Requires: python-visual
Error: Package: rabbitvcs-thunar-0.16-1.el7.x86_64 (epel)
           Requires: thunarx-python
Error: php-pecl-http conflicts with php-pecl-http1-1.7.6-4.el7.x86_64
Error: wxGTK3-devel conflicts with wxGTK-devel-2.8.12-8.el7.x86_64
Error: compat-qpid-tools conflicts with qpid-tools-0.28-4.el7.x86_64
Error: Package: yumex-3.0.15-1.el7.noarch (epel)
           Requires: python-pexpect
Error: Package: pluma-beesu-plugin-0.4-19.el7.x86_64 (epel)
           Requires: pluma
Error: zabbix20 conflicts with zabbix-2.2.3-1.el7.x86_64
Error: Package: yumex-3.0.15-1.el7.noarch (epel)
           Requires: pyxdg
Error: Package: freecad-0.13-10.el7.x86_64 (epel)
           Requires: python-collada
Error: Package: rubygem-term-ansicolor-1.2.2-3.el7.noarch (epel)
           Requires: rubygem(tins) < 1
Error: Package: trac-blackmagictickettweaks-plugin-0.12.2-2.20140425svn9962.el7.noarch (epel)
           Requires: trac >= 0.12
Error: Package: wine-1.7.21-1.el7.x86_64 (epel)
           Requires: wine-pulseaudio(x86-32) = 1.7.21-1.el7
Error: Package: TurboGears-1.1.3-8.el7.noarch (epel)
           Requires: python-paste-script >= 1.7
Error: firebird-superserver conflicts with firebird-classic-common-2.5.2.26539.0-8.el7.x86_64
Error: Package: rabbitvcs-nautilus-0.16-1.el7.x86_64 (epel)
           Requires: nautilus-python
Error: Package: amavisd-new-2.9.1-1.el7.noarch (epel)
           Requires: clamav-server
Error: firebird-classic conflicts with firebird-superclassic-2.5.2.26539.0-8.el7.x86_64
Error: compat-qpid-cpp-server-rdma conflicts with qpid-cpp-server-rdma-0.28-4.el7.x86_64
Error: Package: spectrwm-2.5.0-1.el7.x86_64 (epel)
           Requires: xlockmore
Error: php-pecl-rrd conflicts with rrdtool-php-1.4.8-8.el7.x86_64
Error: Package: fldigi-3.21.83-1.el7.x86_64 (epel)
           Requires: perl(RPC::XML)
Error: Package: php-phpseclib-crypt-aes-0.3.5-2.el7.noarch (epel)
           Requires: php-pear(phpseclib.sourceforge.net/Crypt_Rijndael) >= 0.3.0
Error: Package: TurboGears-1.1.3-8.el7.noarch (epel)
           Requires: python-elixir >= 0.6.1
Error: Package: wine-1.7.21-1.el7.x86_64 (epel)
           Requires: wine-capi(x86-32) = 1.7.21-1.el7
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest



Some of those are purposeful problems, but others are ones about packages needed which may have been in the beta but not anymore and vice versa. Adding a --skip-broken gets me a lot more packages (4503) to install... now to see if I have enough disk space. NOPE. We're gonna need a bigger boat.
Again there are better ways of doing this. I am mostly doing it so I can try out parts of the CentOS environment and how EPEL 7 is looking. My next post will be on how to do this correctly. [Edited after post because I forgot about pre tags which made it unreadable.]
Post a Comment